talc/nix/default.nix
Freya Murphy ca5b3587bc
All checks were successful
docs / test (push) Successful in 10s
webrepl / test (push) Successful in 2m2s
nix: update flake to v0.2.3
2025-02-06 21:50:50 -05:00

31 lines
787 B
Nix

{ pkgs ? import <nixpkgs> { }
, stdenv ? pkgs.stdenv
, lib ? stdenv.lib
, rustPlatform ? pkgs.rustPlatform
, fetchFromGitea ? pkgs.fetchFromGitea
}:
rustPlatform.buildRustPackage rec {
pname = "talc";
version = "0.2.3";
src = fetchFromGitea {
domain = "g.trimill.xyz";
owner = "trimill";
repo = "talc";
rev = "v${version}";
hash = "sha256-8FyRaGTLFv/eLVpt3S4QdeKWIItmZHkQ/gOK4wee0W0=";
};
cargoHash = "sha256-Jp9oAmQXi20y0iMf+fMM4d1WzAwWyYA1+1rbm+MXGyQ=";
meta = with lib; {
description = "magnesium silicate-based programming language and terminal calculator";
homepage = "https://talc.trimill.xyz/";
license = licenses.lgpl3Plus;
maintainers = [{
name = "Freya Murphy";
email = "contact@freyacat.org";
}];
};
}